博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
bzoj1648:奶牛野餐
阅读量:5081 次
发布时间:2019-06-13

本文共 2529 字,大约阅读时间需要 8 分钟。

1648: [Usaco2006 Dec]Cow Picnic 奶牛野餐

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 502  Solved: 307
[ ][ ][ ]

Description

The cows are having a picnic! Each of Farmer John's K (1 <= K <= 100) cows is grazing in one of N (1 <= N <= 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 <= M <= 10,000) one-way paths (no path connects a pasture to itself). The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.

 

  K(1≤K≤100)只奶牛分散在N(1≤N≤1000)个牧场.现在她们要集中起来进餐.牧场之间有M(1≤M≤10000)条有向路连接,而且不存在起点和终点相同的有向路.她们进餐的地点必须是所有奶牛都可到达的地方.那么,有多少这样的牧场呢?

Input

* Line 1: Three space-separated integers, respectively: K, N, and M * Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing. * Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

 第1行输入K,N,M.接下来K行,每行一个整数表示一只奶牛所在的牧场编号.接下来M行,每行两个整数,表示一条有向路的起点和终点

Output

* Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

    所有奶牛都可到达的牧场个数

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4
INPUT DETAILS:
4<--3
^ ^
| |
| |
1-->2
The pastures are laid out as shown above, with cows in pastures 2 and 3.

Sample Output

2
牧场3,4是这样的牧场.

HINT

 

Source

好像写过一道题然后差不多的写法,就是看一下哪一个能到达k次就ok了。注意一下每一个只能到达一次,所以要是存在环的话不能重复添加,开始弄成了死循环了;

---------------------------------------------------------------------------------------------

#include<cstdio>

#include<cstring>
#include<iostream>
#include<algorithm>
#include<deque>
using namespace std;
struct edge{
 int to,next;
};
const int nmax=20005;
edge e[nmax];
int head[1005],c[105],d[1005],v[1005];
void dfs(int x){
 d[x]++;
 v[x]=1;
 for(int j=head[x];j;j=e[j].next){
  if(!v[e[j].to])
      dfs(e[j].to);
 }
}
int main(){
 int n,m,k,cur=0,ans=0;
 memset(head,0,sizeof(head));
 scanf("%d%d%d",&k,&n,&m);
 for(int i=1;i<=k;i++){
  scanf("%d",&c[i]);
 }
 for(int i=1;i<=m;i++){
  int u,o;
  scanf("%d%d",&u,&o);
  cur++;
  e[cur].to=o;
  e[cur].next=head[u];
  head[u]=cur;
 }
 for(int i=1;i<=k;i++){
  memset(v,0,sizeof(v));
  dfs(c[i]);
 }
 for(int i=1;i<=n;i++){
  if(d[i]==k){
   ans++;
  }
 }
 printf("%d\n",ans);
 return 0;
}

--------------------------------------------------------------------------------

转载于:https://www.cnblogs.com/20003238wzc--/p/4818946.html

你可能感兴趣的文章
Android系统--输入系统(十一)Reader线程_简单处理
查看>>
监督学习模型分类 生成模型vs判别模型 概率模型vs非概率模型 参数模型vs非参数模型...
查看>>
Mobiscroll脚本破解,去除Trial和注册时间限制【转】
查看>>
实验五 Java网络编程及安全
查看>>
32位与64位 兼容编程
查看>>
iframe父子页面通信
查看>>
ambari 大数据安装利器
查看>>
java 上传图片压缩图片
查看>>
magento 自定义订单前缀或订单起始编号
查看>>
ACM_拼接数字
查看>>
计算机基础作业1
查看>>
Ubuntu 深度炼丹环境配置
查看>>
C#中集合ArrayList与Hashtable的使用
查看>>
从一个标准 url 里取出文件的扩展名
查看>>
map基本用法
查看>>
poj-1163 动态规划
查看>>
Golang之interface(多态,类型断言)
查看>>
Redis快速入门
查看>>
BootStrap---2.表格和按钮
查看>>
Linear Algebra lecture 2 note
查看>>